Very important information about version 2.0.0 requirements

New version will require PHP in – minimum – version 5.3. This is very important information for all Kocuj Sitemap plugin users who want to update to version 2.0.0 when it will be released, because this can damage website if PHP will be older than version 5.3.

Today there has been released special version of Kocuj Sitemap plugin into the WordPress plugins repository, which has no new features or bug fixes, but which display if your server or hosting account is prepared for the new plugin version.

WordPress versions support policy

There is too often the situation when old version of WordPress is used and no one performs updates. No update of WordPress makes it difficult for plugin developers (such as Kocuj Sitemap) to do technical support and backward compatibility. Therefore, I have decided that from version 2.0.0 of Kocuj Sitemap plugin only 2 versions of WordPress will be supported – the newest and previous. For example, when the latest WordPress version is 4.3, then versions 4.2 and 4.3 will be supported. I have to admit that an attempt to support very old versions of WordPress was one of the main reasons for the lack of any update for the Kocuj Sitemap plugin.

But what should do people with old versions of WordPress? The answer is simple – to update.

Please be aware that an outdated version of WordPress is nothing more but trouble. Sooner or later your website will get hacked. Therefore, WordPress update process should be performed as often as possible.

But why people do not update their WordPress installations? There are often the same few reasons. I will try to argue with them below.